install 'sass' gem explicitly
authorLunar <lunar@anargeek.net>
Tue, 28 Feb 2012 11:26:00 +0000 (12:26 +0100)
committerLunar <lunar@anargeek.net>
Fri, 23 Mar 2012 17:11:28 +0000 (18:11 +0100)
As said by Haml warning:

  Sass is in the process of being separated from Haml,
  and will no longer be bundled at all in Haml 3.2.0.
  Please install the 'sass' gem if you want to use Sass.

Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 1a341c1..a9fed53 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -6,6 +6,7 @@ gem "haml", "~>3.1"
 gem "haml-magic-translations",
   :git    => 'https://dl.poivron.org/new/haml-magic-translations.git',
   :branch => 'coquelicot'
+gem "sass"
 gem "fast_gettext"
 gem "lockfile", "~>1.4.3"
 gem "json"
index 93c535a..af33f18 100644 (file)
@@ -34,6 +34,7 @@ GEM
     rspec-expectations (2.8.0)
       diff-lcs (~> 1.1.2)
     rspec-mocks (2.8.0)
+    sass (3.1.15)
     sinatra (1.3.2)
       rack (~> 1.3, >= 1.3.6)
       rack-protection (~> 1.2)
@@ -66,6 +67,7 @@ DEPENDENCIES
   rack (~> 1.1)
   rack-test (~> 0.5.7)
   rspec (~> 2.0)
+  sass
   sinatra (~> 1.3)
   sinatra-contrib (~> 1.3)
   thin